Finally… I got around to researching a little issue that had been bothering me ever since I installed Ubuntu 12.04 back in April.  Watching videos, flash or otherwise would suffer from frequent skipping (or stuttering) of both the audio and video.  Previously I searched for a solution by searching for “video” stuttering, found some interesting articles that pointed to the nVidia graphics drivers.  But after a few hours of fiddling, nothing seemed to work.

Then, today, I finally got fed up enough to do another search.  This time I searched for stuttering “audio” and I found the holy grail, the fix!  As usual, the Ubuntu forums came to the rescue.

As it turns out, my Intel motherboard audio device may have been incorrectly recognized by Ubuntu and the audio driver may have been having issues.  So here’s how to fix it…

Open a terminal window and type:

sudo nano /etc/modprobe.d/alsa-base.conf

Scroll to the end of the file and then add the following:

options snd-hda-intel model=generic

Press “Ctrl-O” to write to the file then “Ctrl-X” to exit.

That’s about it.  I required a reboot to get it to work, but others mileage may vary.

Was this post helpful?
  • Thanks 
  • Sort-of 
  • Not Helpful 

3 Comments

  1. You had saved my life!!!!!

  2. I have Linux 17.2 Cinnamon Mint. Will this work with skipping audio on videos for my rig? Getting tired of people repeating words, musical phrases repeated at the end, etc! It happens anywhere I watch video, including DVDs.

    • It might? Given that Mint is Ubuntu based, it’s entirely possible that they have the same issue. Audio is an ongoing struggle for me.

Leave a Reply

Your email address will not be published. Required fields are marked *